Debian minimal

From The World according to Vissie
Jump to navigation Jump to search

Here I will explain how I go from Debian minimal to VissieNix Debian

wget https://cdimage.debian.org/debian-cd/current/amd64/iso-cd/debian-9.0.0-amd64-netinst.iso

PLEASE remember to un-tick All the Graphical environments.

After login, lets install:

su
apt-get update
apt-get install subversion

run vissienix script

then, move on to OpenBox install
apt-get upgrade

Error:

perl: warning: Please check that your locale settings:

LANGUAGE = (unset), LC_ALL = (unset), LANG = "en_ZA.UTF-8"

   are supported and installed on your system.

Fix:

dpkg-reconfigure locales

Pick:

[*] en_ZA.UTF-8 UTF-8 

.. and default to

en_UZ.UTF-8

Error:

update-alternatives  warning  skip creation of /usr/share/man because associated file doesn't exist

Fix:

none yet!